diff mbox series

[bug#50628,012/154] gnu: Add trytond-account-credit-limit.

Message ID bc15da1b44f2e1369b80f14f256fee3cfe69f714.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-credit-limit): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 53ec211926..0938c86780 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -293,6 +293,32 @@  chart of account for Belgium.")
 amounts to be rounded using the cash rounding factor of the currency.")
     (license license:gpl3+)))
 
+(define-public trytond-account-credit-limit
+  (package
+    (name "trytond-account-credit-limit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_credit_limit" version))
+       (sha256
+        (base32 "1ni4cfydypxrkdj7fc0j4js9ygfkxa22ii5db2p89z2izbg1hxd8"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_credit_limit"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-dunning" ,trytond-account-dunning)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-company" ,trytond-company)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-account-credit-limit")
+    (synopsis "Tryton module for account credit limit")
+    (description "The @emph{Account Credit Limit} Tryton module for manages
+credit limit of parties.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice
   (package
     (name "trytond-account-invoice")