diff mbox series

[bug#50628,077/154] gnu: Add trytond-product-kit.

Message ID 8225c11b9b50ead5e8ace257a59b828a4bd9988c.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-product-kit): New variable.
---
 gnu/packages/tryton.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3ae0f3777a..c2d8f616c9 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2273,6 +2273,36 @@  and assets.")
 cost price of products to be calculated separately for each warehouse.")
     (license license:gpl3+)))
 
+(define-public trytond-product-kit
+  (package
+    (name "trytond-product-kit")
+    (version "6.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_kit" version))
+       (sha256
+        (base32 "1xr1vd66lrnzj16ycbw5xnz4ai44ml77akhsvxvihf09zdz09yd7"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_kit"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
+       ("trytond-company" ,trytond-company)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)))
+    (home-page "https://docs.tryton.org/projects/modules-product-kit")
+    (synopsis "Tryton module to manage product kits and components")
+    (description "The @emph{Product Kit} Tryton Module adds kits and
+components to products.  This enables a defined set of products to be sold or
+purchased using a single line.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")