diff mbox series

[bug#50628,011/154] gnu: Add trytond-account-cash-rounding.

Message ID d66f7a2e88f4cbc6361003044847ddc371b48b38.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-cash-rounding): New variable.
---
 gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d47de2e2ae..53ec211926 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -265,6 +265,34 @@  of fixed assets.")
 chart of account for Belgium.")
     (license license:gpl3+)))
 
+(define-public trytond-account-cash-rounding
+  (package
+    (name "trytond-account-cash-rounding")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_cash_rounding" version))
+       (sha256
+        (base32 "15xl36929zgfw9rlwaqdqs5l4ijspfx8i060z6884p2nizhh69s5"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_cash_rounding"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-sale" ,trytond-sale)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-currency" ,trytond-currency)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-cash-rounding")
+    (synopsis "Tryton module to round cash amount")
+    (description "The @emph{Account Cash Rounding} Tryton module allows cash
+amounts to be rounded using the cash rounding factor of the currency.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice
   (package
     (name "trytond-account-invoice")