diff mbox series

[bug#50628,044/154] gnu: Add trytond-account-tax-rule-country.

Message ID 4c6363c3302d7193679e6e52ab43e432e073c900.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-tax-rule-country): New variable.
---
 gnu/packages/tryton.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7bfe144299..497a7ad193 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1251,6 +1251,36 @@  from the Product Measurements")
 report on cash basis.")
     (license license:gpl3+)))
 
+(define-public trytond-account-tax-rule-country
+  (package
+    (name "trytond-account-tax-rule-country")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_tax_rule_country" version))
+       (sha256
+        (base32 "0gy2zp023d2wqcivaiw5db5d8f4wrpqdnd6jywjhpkvqk4ay6i27"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_tax_rule_country"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-country" ,trytond-country)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-tax-rule-country")
+    (synopsis "Tryton module to add countries on tax rules")
+    (description "The @emph{Account Tax Rule Country} Tryton module extends
+the tax rule to add origin and destination countries and subdivisions as
+criteria.")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-account
   (package
     (name "trytond-analytic-account")