diff mbox series

[bug#50628,055/154] gnu: Add trytond-commission.

Message ID 63fe93ff7f37a27cc2741fb0b19077a6842c1132.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-commission): New variable.
---
 gnu/packages/tryton.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 66d755ff3f..3320c3a30b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1572,6 +1572,36 @@  or a specific postal code.")
 the weight is greater or equal but smaller than the next line.")
     (license license:gpl3+)))
 
+(define-public trytond-commission
+  (package
+    (name "trytond-commission")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_commission" version))
+       (sha256
+        (base32 "0a5grn6gvvwn0prr5fpgyj4kz283w08a8svmv3b4a4c5pchik3hv"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "commission"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-sale" ,trytond-sale)))
+    (propagated-inputs
+     `(("python-simpleeval" ,python-simpleeval)
+       ("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-product" ,trytond-account-product)
+       ("trytond-party" ,trytond-party)
+       ("trytond-product" ,trytond-product)))
+    (home-page "https://docs.tryton.org/projects/modules-commission")
+    (synopsis "Tryton module for commission")
+    (description "The @emph{Commission} Tryton module allows to manageq
+commission for sale's agents.  A commission move is created when posting the
+invoice, following the agent's commission plan.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")