diff mbox series

[bug#50628,152/154] gnu: Add trytond-web-shop-vue-storefront-stripe.

Message ID 99728efbcb58ab7bc557c29db9f7df508d95219f.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-web-shop-vue-storefront-stripe): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d108610e0d..cc57037a77 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4423,3 +4423,29 @@  configuration of an online web shop.")
     (description "This Tryton module provides the back-end to integrate with
 Vue Storefront 1.x.")
     (license license:gpl3+)))
+
+(define-public trytond-web-shop-vue-storefront-stripe
+  (package
+    (name "trytond-web-shop-vue-storefront-stripe")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_web_shop_vue_storefront_stripe" version))
+       (sha256
+        (base32 "0j4yv9q0f39bkyqlcn7kpnlqi9wc4qfjs8zic69za6xw2c86zgzm"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "web_shop_vue_storefront_stripe"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-payment-stripe" ,trytond-account-payment-stripe)
+       ("trytond-sale-payment" ,trytond-sale-payment)
+       ("trytond-web-shop" ,trytond-web-shop)
+       ("trytond-web-shop-vue-storefront" ,trytond-web-shop-vue-storefront)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-web-shop-vue-storefront-stripe")
+    (synopsis "Tryton module to support Stripe payment with Vue Storefront")
+    (description "The @emph{Web Shop Vue Storefront Stripe} Tryton module
+provides support of Stripe payment for Vue Storefront integration.")
+    (license license:gpl3+)))