diff mbox series

[bug#50628,023/154] gnu: Add trytond-account-invoice-correction.

Message ID 44523eb0cd1ad9ba878fe51a35a2ddfcc906a29c.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-invoice-correction): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4b588f5974..0a57265067 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -628,6 +628,31 @@  term.")
 (define-public python-trytond-account-invoice
   (deprecated-package "python-trytond-account-invoice" trytond-account-invoice))
 
+(define-public trytond-account-invoice-correction
+  (package
+    (name "trytond-account-invoice-correction")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_invoice_correction" version))
+       (sha256
+        (base32 "152jxsl6v2wclk1wjhykbyvianh47cp2yg575hkx18dfynyp7nmw"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_invoice_correction"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-invoice-correction")
+    (synopsis "Tryton module to correct invoice")
+    (description "The @emph{Account Invoice Correction} Tryton module adds a
+wizard on invoice which allows select lines for which the unit price must be
+corrected.  A new invoice is created with those lines in double: once with the
+original quantity, once with the inverted quantity.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice-stock
   (package
     (name "trytond-account-invoice-stock")