diff mbox series

[bug#50628,147/154] gnu: Add trytond-timesheet.

Message ID d9c44b8e802025d63576039b7dc29eb651a01cfe.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-timesheet): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 202ccd29f1..db44d325a8 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4287,3 +4287,28 @@  forecast into account to compute purchase requests.")
     (description "The @emph{Stock Supply Production} module adds automatic
 supply mechanisms via production request.")
     (license license:gpl3+)))
+
+(define-public trytond-timesheet
+  (package
+    (name "trytond-timesheet")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_timesheet" version))
+       (sha256
+        (base32 "0airh5jvcdjbkb71p684dr5qgsnpam2hhmq6gswclgnx3nd1lz6a"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "timesheet"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-company-work-time" ,trytond-company-work-time)))
+    (home-page "https://docs.tryton.org/projects/modules-timesheet")
+    (synopsis "Tryton module with timesheets")
+    (description "The @emph{Timesheet} Tryton module allows to track the time
+spent by employees on various works.  This module also comes with several
+reports that show the time spent by employees on works following various time
+periods.")
+    (license license:gpl3+)))