diff mbox series

[bug#50628,149/154] gnu: Add trytond-user-role.

Message ID 4be444a0c8c8a6ca4b2ec718fefd88c2aebf2dee.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-user-role): New variable.
---
 gnu/packages/tryton.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 391a5330cb..9c605ca989 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4336,3 +4336,26 @@  periods.")
     (description "The @emph{Timesheet Cost} Tryton module adds cost price per
 employee.")
     (license license:gpl3+)))
+
+(define-public trytond-user-role
+  (package
+    (name "trytond-user-role")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_user_role" version))
+       (sha256
+        (base32 "11sjz46kagrpig5n05pp52yph4z0l1zm140q9wsagjcmzkx7s6gf"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "user_role"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)))
+    (home-page "https://docs.tryton.org/projects/modules-user-role")
+    (synopsis "Tryton module to manage roles on users")
+    (description "This package provides a Tryton module for assigning roles to
+user instead of groups.  A Role is defined by a set of groups.  When a role is
+added to a user, it overrides the existing groups.  A role can be added to a
+user for a period of time only.")
+    (license license:gpl3+)))