diff mbox series

[bug#50628,133/154] gnu: Add trytond-stock-lot-unit.

Message ID d4f4b4f1523c85bea430e2bd0bcd2114182b8147.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-lot-unit): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 2a45791eb0..42eb8b8b89 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3893,6 +3893,32 @@  the shelf life of a lot expires in less than the configured shelf life delay,
 it is no more used to compute the forecast quantity of the stock.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-lot-unit
+  (package
+    (name "trytond-stock-lot-unit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_lot_unit" version))
+       (sha256
+        (base32 "1acvrj9af83gmfcp7kgyi37kv3v5910rh1q73scd37xbv7h8dyrm"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_lot_unit"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-production" ,trytond-production)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)
+       ("trytond-stock-lot" ,trytond-stock-lot)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-lot-unit")
+    (synopsis "Tryton module to define unit on stock lot")
+    (description "The @emph{Stock Lot Unit} Tryton module allows to define a
+unit and quantity on stock lot.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")