diff mbox series

[bug#50628,039/154] gnu: Add trytond-account-stock-anglo-saxon.

Message ID b4dbcf2056413dd2b4e5ede99fdf53b6c810a84b.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-stock-anglo-saxon): New variable.
---
 gnu/packages/tryton.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 6646dc6918..61fe36ce9b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1109,6 +1109,39 @@  found that matches.  Then the rule found is used to create the statement lines
 linked to the origin.")
     (license license:gpl3+)))
 
+(define-public trytond-account-stock-anglo-saxon
+  (package
+    (name "trytond-account-stock-anglo-saxon")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_stock_anglo_saxon" version))
+       (sha256
+        (base32 "090a4ykrlk2xpqxqhmpa2jrbjkrvhibm60ilp1n28wisbgv9d3di"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_stock_anglo_saxon"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-supply-drop-shipment"
+        ,trytond-sale-supply-drop-shipment)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
+       ("trytond-account-product" ,trytond-account-product)
+       ("trytond-account-stock-continental"
+        ,trytond-account-stock-continental)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-stock-anglo-saxon")
+    (synopsis "Tryton module for anglo-saxon real-time stock valuation")
+    (description "The @emph{Account Stock Anglo Saxon} Tryton module adds the
+anglo-saxon accounting model for stock valuation.")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-account
   (package
     (name "trytond-analytic-account")