diff mbox series

[bug#50628,059/154] gnu: Add trytond-dashboard.

Message ID a0dfd72527859ccb93576fec82a921cc406fc2e8.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-dashboard): New variable.
---
 gnu/packages/tryton.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4f7bd60d12..aea203cd8c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1762,6 +1762,27 @@  currency and rate.")
 duty based on the tariff code.")
     (license license:gpl3+)))
 
+(define-public trytond-dashboard
+  (package
+    (name "trytond-dashboard")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_dashboard" version))
+       (sha256
+        (base32 "1drqiks8r7y58wz0skfa39v9yqx9fi5x0ymrrjd87wybw9q3kv46"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "dashboard"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)))
+    (home-page "https://docs.tryton.org/projects/modules-dashboard")
+    (synopsis "Tryton module for dashboard")
+    (description "The @emph{Dashboard} Tryton module allows users to
+configure their dashboard.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")