diff mbox series

[bug#50628,091/154] gnu: Add trytond-project-revenue.

Message ID af35308a464a871375c9a8494f622084e67806e4.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-project-revenue): New variable.
---
 gnu/packages/tryton.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index f56a1924ac..29e197893c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2628,6 +2628,38 @@  methods on projects.  The methods are:  FIXME")
 on top of the Project module.")
     (license license:gpl3+)))
 
+(define-public trytond-project-revenue
+  (package
+    (name "trytond-project-revenue")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_project_revenue" version))
+       (sha256
+        (base32 "0gji7kpq4l1smxvj6dqdpcyp2ml4ywfhagf6xm813y71mrlfvmka"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "project_revenue"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-purchase" ,trytond-purchase)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-project" ,trytond-project)
+       ("trytond-timesheet" ,trytond-timesheet)
+       ("trytond-timesheet-cost" ,trytond-timesheet-cost)))
+    (home-page "https://docs.tryton.org/projects/modules-project-revenue")
+    (synopsis "Tryton module to add revenue on project")
+    (description "The @emph{Project Revenue} Tryton module computes revenue
+and cost per task and project.  The revenue uses the list price of the
+product.  If the product's unit of measure is time based, the revenue is
+computed as the product of the price and the hours of effort otherwise the
+price is considered as fixed.  The cost is computed by summing the cost of all
+the linked time sheets and the linked purchase lines.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")