diff mbox series

[bug#50628,036/154] gnu: Add trytond-account-statement-coda.

Message ID d2dd93c23b9241e0cc8207bd53c6457e791854d3.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-statement-coda): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 2a79a3823b..7410d4c3d7 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1025,6 +1025,32 @@  the import of @emph{Norm 43} files as statement.  @emph{Norm 43} is a standard
 defined by the Spanish banking association.")
     (license license:gpl3+)))
 
+(define-public trytond-account-statement-coda
+  (package
+    (name "trytond-account-statement-coda")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_statement_coda" version))
+       (sha256
+        (base32 "11gryxh2b2py0h6f89nj2y42cwb8rrxjn0r5jbhrcsfhb2kh1x3w"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_statement_coda"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-febelfin-coda" ,python-febelfin-coda)
+       ("trytond" ,trytond)
+       ("trytond-account-statement" ,trytond-account-statement)
+       ("trytond-bank" ,trytond-bank)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-statement-coda")
+    (synopsis "Tryton module to import CODA statements")
+    (description "The @emph{Account Statement CODA} Tryton module implements
+the import of @emph{CODA} files as statement.  @emph{CODA} is a standard
+defined by Belgian \"febelfin\".")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-account
   (package
     (name "trytond-analytic-account")