diff mbox series

[bug#50628,129/154] gnu: Add trytond-stock-inventory-location.

Message ID 2df02bc3fd705b760338318e64b41d49b52cf301.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-inventory-location): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d5e1d7b331..9568d82b0d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3768,6 +3768,31 @@  to create stock moves toward customers with a date in the future.  This allows
 other stock mecanisms to anticipate customer demand.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-inventory-location
+  (package
+    (name "trytond-stock-inventory-location")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_inventory_location" version))
+       (sha256
+        (base32 "0mvgday5qhmx89xikklr2ad2xa7zxkiysxa2bqsf76imvx4801q6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_inventory_location"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-inventory-location")
+    (synopsis "Tryton module to create inventories by locations")
+    (description "The @emph{Stock Inventory Location} Tryton module adds a new
+wizard \"Create Inventories\" under the \"Inventories\" sub-menu.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")