diff mbox series

[bug#50628,102/154] gnu: Add trytond-sale-amendment.

Message ID 44dd757b4506a3db7646ab44da94b1f780772b3d.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-amendment): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 305719c614..4669538fd4 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3012,6 +3012,32 @@  to be generated that contain aggregated sales figures.")
 for advance payment management on the sale.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-amendment
+  (package
+    (name "trytond-sale-amendment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_amendment" version))
+       (sha256
+        (base32 "1vkcyfp30hng2vj1h1pvwrlvp9b59pkzzlmgnj6gvs867l8f2zva"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_amendment"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-history" ,trytond-sale-history)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-amendment")
+    (synopsis "Tryton module to amend sales")
+    (description "The @emph{Sale Amendment} Tryton module allows you to change
+sales that are being processed and keep track of the changes.  An amendment is
+composed of action lines which can:")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")