diff mbox series

[bug#50628,025/154] gnu: Add trytond-account-invoice-history.

Message ID 4e81ff5006066b5d441224ea8cd000fdc53292b0.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-invoice-history): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 89da265a7f..a9e3759f13 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -678,6 +678,30 @@  original quantity, once with the inverted quantity.")
 defer the expense or the revenue of an invoice line over many periods.")
     (license license:gpl3+)))
 
+(define-public trytond-account-invoice-history
+  (package
+    (name "trytond-account-invoice-history")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_invoice_history" version))
+       (sha256
+        (base32 "0pq1raj6v76vqsb2mk1bfv1vg1ngfk9iiai30rlzj2zcl53phcvj"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_invoice_history"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-party" ,trytond-party)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-invoice-history")
+    (synopsis "Tryton module to historize invoices")
+    (description "The @emph{Account Invoice History} Tryton module activates
+the historization of the invoice and its related fields.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice-stock
   (package
     (name "trytond-account-invoice-stock")