diff mbox series

[bug#50628,069/154] gnu: Add trytond-party-relationship.

Message ID e640927ade9051c515d9ad968b6975c84014e0d9.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-party-relationship): New variable.
---
 gnu/packages/tryton.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 60cdbd7692..e89549b6ce 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2054,6 +2054,28 @@  addresses.")
 party.")
     (license license:gpl3+)))
 
+(define-public trytond-party-relationship
+  (package
+    (name "trytond-party-relationship")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_party_relationship" version))
+       (sha256
+        (base32 "03lkjmhinxm75schfn596vyg8459fx2spdyh372ikra3zdp8pg75"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "party_relationship"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-party-relationship")
+    (synopsis "Party Relationship module for Tryton")
+    (description "The @emph{Party Relationship} Tryton module allows to define
+different types of relations between parties.")
+    (license license:gpl3+)))
+
 (define-public trytond-product
   (package
     (name "trytond-product")