diff mbox series

[bug#50628,121/154] gnu: Add trytond-sale-subscription.

Message ID 0da9c6a6c6284e43b6f4a5e9d86c5f11bff3e303.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-subscription): New variable.
---
 gnu/packages/tryton.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index de53e118e9..17c92c6b88 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3515,6 +3515,33 @@  supply) is lower than the quantity sold by considering other sales and the
 stock forecasts.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-subscription
+  (package
+    (name "trytond-sale-subscription")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_subscription" version))
+       (sha256
+        (base32 "092ljl0ywybwchp4qfki752nclqc6hkx2h99cd1h3g998jv3l72x"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_subscription"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-subscription")
+    (synopsis "Tryton module for subscription")
+    (description "The @emph{Sale Subscription} module defines subscription,
+services and recurrence rule models.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")