diff mbox series

[bug#50628,117/154] gnu: Add trytond-sale-shipment-cost.

Message ID e932ac3b6956c2a1151de2ff8637142ab12d03a6.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-shipment-cost): New variable.
---
 gnu/packages/tryton.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 1b13caec1c..8cf440cc04 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3403,6 +3403,36 @@  price are kept synchronized with the quantity and unit price.  The secondary
 unit is defined on the product with its factor against the sale unit.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-shipment-cost
+  (package
+    (name "trytond-sale-shipment-cost")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_shipment_cost" version))
+       (sha256
+        (base32 "1h1qhp90f8mzx2px48fa8xsgwhbf2gkg8q94vghy696a3hh1xzxb"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_shipment_cost"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-sale-promotion" ,trytond-sale-promotion)
+       ("trytond-stock-shipment-cost" ,trytond-stock-shipment-cost)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-carrier" ,trytond-carrier)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-shipment-cost")
+    (synopsis "Tryton module for sale shipment cost")
+    (description "The @emph{Sale Shipment Cost} Tryton module adds shipment
+cost for sale.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")