diff mbox series

[bug#50628,046/154] gnu: Add trytond-analytic-purchase.

Message ID b9d844a21b21fcd71c2c20ddd42a5da703845932.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-analytic-purchase): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index f950b9b844..9ef5178598 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1336,6 +1336,30 @@  required to analyse accounting using multiple different axes.")
 analytic accounts on invoice line.")
     (license license:gpl3+)))
 
+(define-public trytond-analytic-purchase
+  (package
+    (name "trytond-analytic-purchase")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_analytic_purchase" version))
+       (sha256
+        (base32 "1yx3w3p98y11qw99jy02kal9393y6jpxazsfcznsffgigw2vl3y6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "analytic_purchase"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-analytic-account" ,trytond-analytic-account)
+       ("trytond-analytic-invoice" ,trytond-analytic-invoice)
+       ("trytond-purchase" ,trytond-purchase)))
+    (home-page "https://docs.tryton.org/projects/modules-analytic-purchase")
+    (synopsis "Tryton module to add analytic accounting on purchase")
+    (description "The @emph{Analytic Purchase} Tryton module allows to set
+analytic accounts on purchase line.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")