diff mbox series

[bug#50628,100/154] gnu: Add trytond-sale.

Message ID 09442b6ca91b2eef23005ad64c8665e052f99e97.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale): New variable.
---
 gnu/packages/tryton.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 72edef4f8a..25afb5ae3f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2950,6 +2950,40 @@  the product with its factor against the purchase unit.")
 shipment costs to Supplier Shipment.")
     (license license:gpl3+)))
 
+(define-public trytond-sale
+  (package
+    (name "trytond-sale")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale" version))
+       (sha256
+        (base32 "0wk5lhj74vl7zs4l3x176iwfqr3jnq37xhiksgnajsrjrl54bgfg"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
+       ("trytond-account-product" ,trytond-account-product)
+       ("trytond-company" ,trytond-company)
+       ("trytond-country" ,trytond-country)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-party" ,trytond-party)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale")
+    (synopsis "Tryton module for sale")
+    (description "The @emph{Sale} Tryton module helps organise and manage
+sales made by the company.  It adds the concept of a sale to Tryton and allows
+it to be tracked through its states from draft to done.  It also oversees the
+creation of customer shipments and invoices for the sales, and allows reports
+to be generated that contain aggregated sales figures.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")