diff mbox series

[bug#50628,087/154] gnu: Add trytond-production-work-timesheet.

Message ID 24e55aed39da1c146283bdaafc92c4eae2d602e4.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-production-work-timesheet): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 346d354b38..35388eda8f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2526,6 +2526,31 @@  work order for each production.  It also adds in the production cost for the
 work cost.")
     (license license:gpl3+)))
 
+(define-public trytond-production-work-timesheet
+  (package
+    (name "trytond-production-work-timesheet")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_production_work_timesheet" version))
+       (sha256
+        (base32 "1r7k25wddd381g0p5pj3m8jqvbg8g6ss0ifnhhjya3b6x0d41jz9"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "production_work_timesheet"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-production-routing" ,trytond-production-routing)
+       ("trytond-production-work" ,trytond-production-work)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-production-work-timesheet")
+    (synopsis "Tryton module for timesheet on production work")
+    (description "The @emph{Production Work Timesheet} Tryton module allows to
+enter timesheet for production works.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")