diff mbox series

[bug#50628,137/154] gnu: Add trytond-stock-product-location.

Message ID 0d74f08b5b143e2995a8982de00ef5ef1b794c45.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-product-location): New variable.
---
 gnu/packages/tryton.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 74d46fee1b..bcd95f2b13 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4003,6 +4003,35 @@  interact with shipping service providers.")
 you to generate the UPS labels per package using the UPS webservices.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-product-location
+  (package
+    (name "trytond-stock-product-location")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_product_location" version))
+       (sha256
+        (base32 "1r0a9pkyjh1n0xhax583v80fawnszxaf9q8r3851325an2rmndx8"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_product_location"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-production" ,trytond-production)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-product-location")
+    (synopsis "Tryton module to add default location on product")
+    (description "The @emph{Stock Product Location} Tryton module adds on the
+product form a list of preferred location by warehouse.  This list is used
+when a supplier shipment is received: the auto-generated Inventory Moves will
+use as default destination the preferred locations associated to the current
+warehouse.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")