diff mbox series

[bug#50628,107/154] gnu: Add trytond-sale-gift-card.

Message ID 2d8d0607ad05a4d730dff06df07eb7fff378c01f.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-gift-card): New variable.
---
 gnu/packages/tryton.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index cb2b085375..3f5de66e9e 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3139,6 +3139,33 @@  line.")
 on sale based on criteria.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-gift-card
+  (package
+    (name "trytond-sale-gift-card")
+    (version "6.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_gift_card" version))
+       (sha256
+        (base32 "0bbcgm7xs5hmn3axz62jkarhl9v43nk9mk9zldlf9qrfqy89fd80"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_gift_card"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-gift-card")
+    (synopsis "Tryton module to manage gift cards")
+    (description "The @emph{Sale Gift Card} Tryton module manages the selling
+and redeeming of gift cards.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")