diff mbox series

[bug#67902,94/95] gnu: Add php-webmozart-assert.

Message ID 20231219140934.22783-94-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-webmozart-assert): New variable.

Change-Id: I4ab034d68ea7d13098292b7df1ae2405e9ea662b
---
 gnu/packages/php-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index fc36464698..9bd64cdf40 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2562,3 +2562,27 @@  (define-public php-twig-twig
     (home-page "https://twig.symfony.com")
     (license license:bsd-3)))
 
+(define-public php-webmozart-assert
+  (package
+    (name "php-webmozart-assert")
+    (version "1.11.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/webmozarts/assert")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1i2fcyz5xmfs7dz7gwds1fkqzzvw35six0bqmi0yvkxnc54q3wj1"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-symfony-polyfill-ctype))
+    (synopsis "Assertions to validate method I/O with nice error messages")
+    (description "This library contains efficient assertions to test the input
+and output of PHP methods.")
+    (home-page "https://github.com/webmozarts/assert")
+    (license license:expat)))
+