diff mbox series

[bug#67902,54/95] gnu: Add php-symfony-cache.

Message ID 20231219140934.22783-54-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-cache): New variable.

Change-Id: I08ee7e14f2571970d9555ff9593703308820656a
---
 gnu/packages/php-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index e31d112e8b..8a6e5ca416 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1365,3 +1365,39 @@  (define-public php-sebastian-version
     (home-page "https://github.com/sebastianbergmann/version")
     (license license:bsd-3)))
 
+(define-public php-symfony-cache
+  (package
+    (name "php-symfony-cache")
+    (version "6.3.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/cache")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1sg9wrzaarylzf4r1kndgf6m6a4s0i0wnnz84ycj43xbv2dll2q3"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-psr-cache
+           php-psr-log
+           php-symfony-cache-contracts
+           php-symfony-service-contracts
+           php-symfony-var-exporter))
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-cache-integration-tests
+           php-doctrine-dbal
+           php-psr-simple-cache
+           php-symfony-dependency-injection
+           php-symfony-filesystem
+           php-symfony-http-kernel
+           php-symfony-phpunit-bridge))
+    (synopsis "Complete PHP cache library")
+    (description "This package provides an extended implementation of the PHP
+PSR-6 caching interface, the PHP PSR-16 common interface for caching
+libraries.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+