diff mbox series

[bug#67902,91/95] gnu: Add php-doctrine-dbal.

Message ID 20231219140934.22783-91-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-dbal): New variable.

Change-Id: Ifb88a4da25e138ee22448237604d448332878ae9
---
 gnu/packages/php-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 2b246dee1e..125b9d0069 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2478,3 +2478,39 @@  (define-public php-doctrine-annotations
     (home-page "https://www.doctrine-project.org/projects/annotations")
     (license license:expat)))
 
+;; This package is placed here because it needs to be defined after
+;; php-symfony-cache due to package inheritance.
+(define-public php-doctrine-dbal
+  (package
+    (name "php-doctrine-dbal")
+    (version "3.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/dbal")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fj68qx0bsczc0hh5y86zk9a5p693lx0sav8lidrz5nagqjhlnf2"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--bootstrap" "vendor/autoload.php")))
+    (inputs
+     (list php-doctrine-deprecations php-psr-cache php-psr-log))
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-doctrine-cache
+           php-doctrine-event-manager
+           php-fig-log-test
+           (package/inherit php-symfony-cache
+             (arguments '(#:tests? #f))
+             (native-inputs '()))
+           php-symfony-console))
+    (synopsis "Handle databases in PHP")
+    (description
+     "This package provides a PHP database abstraction layer (DBAL) with many
+features for database schema introspection and management.")
+    (home-page "https://www.doctrine-project.org/projects/dbal")
+    (license license:expat)))
+