diff mbox series

[bug#67902,20/95] gnu: Add php-phpdocumentor-reflection-common.

Message ID 20231219140934.22783-20-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpdocumentor-reflection-common): New variable.

Change-Id: I50bdc401ee32e068ae01724f7b1ac3b09bb7e66f
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 87889eae11..5bcae5d4ed 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -537,3 +537,25 @@  (define-public php-phar-io-version
     (home-page "https://phar.io")
     (license license:bsd-3)))
 
+(define-public php-phpdocumentor-reflection-common
+  (package
+    (name "php-phpdocumentor-reflection-common")
+    (version "2.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/phpDocumentor/ReflectionCommon")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1q685cpwbfxqy42iz61xxv6zbcc1qskn07nkipflj6c5s935l8jy"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Common reflection classes for phpdocumentor")
+    (description "This package contains common classes used by phpdocumentor
+to analyze the code structure.")
+    (home-page "http://www.phpdoc.org")
+    (license license:expat)))
+