diff mbox series

[bug#67902,56/95] gnu: Add php-symfony-cache-contracts.

Message ID 20231219140934.22783-56-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-cache-contracts): New variable.

Change-Id: I56a7534b544b5c6ab05f94e7d68fec746b3096e0
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index b9f71d9073..84c9e4878d 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1443,3 +1443,25 @@  (define-public php-cache-integration-tests
     (home-page "https://github.com/php-cache/integration-tests")
     (license license:expat)))
 
+(define-public php-symfony-cache-contracts
+  (package
+    (name "php-symfony-cache-contracts")
+    (version "3.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/cache-contracts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pjdcm7zwvhf0dcnb7h1c65zc9xpj551dlljag4nliq7i23ypj5y"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-psr-cache))
+    (synopsis "PHP caching abtractions")
+    (description "This package provides PHP generic abstractions related to
+caching.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+