diff mbox series

[bug#67902,90/95] gnu: Add php-doctrine-annotations.

Message ID 20231219140934.22783-90-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-annotations): New variable.

Change-Id: Ifd8f2f247f94b47833e6ef8b80788f3a3e9dcca4
---
 gnu/packages/php-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 036554b8ab..2b246dee1e 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2449,3 +2449,32 @@  (define-public php-doctrine-cache
     (home-page "https://www.doctrine-project.org/projects/cache")
     (license license:expat)))
 
+;; This package is placed here because it needs to be defined after
+;; php-symfony-cache due to package inheritance.
+(define-public php-doctrine-annotations
+  (package
+    (name "php-doctrine-annotations")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/annotations")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "04hsykqcigvmv6rvwjay5scvjji6rcqzwdw9clzfa3xx50mbz38n"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-doctrine-lexer php-psr-cache))
+    (native-inputs
+     (list php-phpunit-phpunit
+           (package/inherit php-symfony-cache
+             (arguments '(#:tests? #f))
+             (native-inputs '()))))
+    (synopsis "Docblock PHP Annotations Parser")
+    (description
+     "This package provides a Docblock PHP Annotations Parser.")
+    (home-page "https://www.doctrine-project.org/projects/annotations")
+    (license license:expat)))
+