diff mbox series

[bug#67902,11/95] gnu: Add php-dms-phpunit-arraysubset-asserts.

Message ID 20231219140934.22783-11-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-dms-phpunit-arraysubset-asserts): New variable.

Change-Id: I77869b75a9dbe28d3ae80de25ba2949f4648c078
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 34cd9cc3a3..a470ab9ed9 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -264,3 +264,25 @@  (define-public php-doctrine-persistence
     (home-page "https://www.doctrine-project.org/projects/persistence")
     (license license:expat)))
 
+(define-public php-dms-phpunit-arraysubset-asserts
+  (package
+    (name "php-dms-phpunit-arraysubset-asserts")
+    (version "0.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rdohms/phpunit-arraysubset-asserts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1hqr99yzppsvv05dscidp2x9acmgpixv39309cv2rwj13qy41hh3"))))
+    (build-system composer-build-system)
+    (inputs (list php-phpunit-phpunit))
+    (synopsis "PHP ArraySubset")
+    (description
+     "This package provides PHP ArraySubset and related asserts once
+deprecated in PHPUnit 8.")
+    (home-page "https://github.com/rdohms/phpunit-arraysubset-asserts")
+    (license license:expat)))
+