diff mbox series

[bug#67902,43/95] gnu: Add php-sebastian-diff.

Message ID 20231219140934.22783-43-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-diff): New variable.

Change-Id: I1b94c3afca08b8df079ee3a22006f3adb4d4324a
---
 gnu/packages/php-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 2a671e37c3..51a96948b3 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1096,3 +1096,24 @@  (define-public php-sebastian-complexity
     (home-page "https://github.com/sebastianbergmann/complexity")
     (license license:bsd-3)))
 
+(define-public php-sebastian-diff
+  (package
+    (name "php-sebastian-diff")
+    (version "4.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/diff")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pxy6g7q5q0nr3yiyimf2dbm0m80dx440mc8p2j2z2fccpyj85dd"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list git-minimal php-phpunit-phpunit php-symfony-process))
+    (synopsis "Diff implementation")
+    (description "This package contains a PHP implementation of a diff function.")
+    (home-page "https://github.com/sebastianbergmann/diff")
+    (license license:bsd-3)))
+