diff mbox series

[bug#67902,63/95] gnu: Add php-symfony-event-dispatcher-contracts.

Message ID 20231219140934.22783-63-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-event-dispatcher-contracts): New variable.

Change-Id: If1222680634687bce31050c604b93e386489931d
---
 gnu/packages/php-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 1d5f033585..97fba315e0 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1683,3 +1683,24 @@  (define-public php-symfony-event-dispatcher
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-event-dispatcher-contracts
+  (package
+    (name "php-symfony-event-dispatcher-contracts")
+    (version "3.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/event-dispatcher-contracts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1l2vigh39v7a4kcx3jxllsd0flvhanhidr61dvvf653v7ll8igk3"))))
+    (build-system composer-build-system)
+    (inputs (list php-psr-event-dispatcher))
+    (synopsis "PHP abstractions for event handling")
+    (description "This package provides generic abstractions related to
+dispatching event in PHP.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+