diff mbox series

[bug#67902,61/95] gnu: Add php-symfony-error-handler.

Message ID 20231219140934.22783-61-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-error-handler): New variable.

Change-Id: Ie8fdaf7a409a1762039992c1c4118eb81b57bcf5
---
 gnu/packages/php-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 9aa2badffb..98e11e860c 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1626,3 +1626,27 @@  (define-public php-symfony-deprecation-contracts
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-error-handler
+  (package
+    (name "php-symfony-error-handler")
+    (version "6.0.19")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/error-handler")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vvpmx5v6b22ip44vs3lgyxk0m5cfwkgdpd8rfpp6lbh61ildcph"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-psr-log php-symfony-var-dumper))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Ease debugging in PHP")
+    (description "This package provides tools to manage errors and ease
+debugging PHP code.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+