diff mbox series

[bug#67902,37/95] gnu: Add php-psr-simple-cache.

Message ID 20231219140934.22783-37-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-psr-simple-cache): New variable.

Change-Id: Ibefc321e391d0501ed4c53345aa053df972bbb8f
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index f9cf7e5210..8bccc9e04b 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -960,3 +960,23 @@  (define-public php-psr-event-dispatcher
     (home-page "https://github.com/php-fig/event-dispatcher")
     (license license:expat)))
 
+(define-public php-psr-simple-cache
+  (package
+    (name "php-psr-simple-cache")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/php-fig/simple-cache")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0gndf4ygvgbw790hxxvv9d2qpnzdi409m1n9f36jw7fy1cg6gbax"))))
+    (build-system composer-build-system)
+    (synopsis "Simple cache in PHP")
+    (description "This package provides common interfaces in PHP for simple
+caching.")
+    (home-page "https://github.com/php-fig/simple-cache")
+    (license license:expat)))
+