diff mbox series

[bug#67902,21/95] gnu: Add php-phpdocumentor-reflection-docblock.

Message ID 20231219140934.22783-21-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpdocumentor-reflection-docblock): New variable.

Change-Id: Ia309917aa0dfda04c1b024c91bb10c73a8aa976b
---
 gnu/packages/php-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 5bcae5d4ed..8f72e6ce0b 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -559,3 +559,38 @@  (define-public php-phpdocumentor-reflection-common
     (home-page "http://www.phpdoc.org")
     (license license:expat)))
 
+(define-public php-phpdocumentor-reflection-docblock
+  (package
+    (name "php-phpdocumentor-reflection-docblock")
+    (version "5.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/phpDocumentor/ReflectionDocBlock")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0d7j45b84191f0z8fn5a9fmfjfc3apa9g02pbm4b27w4yybfaqjj"))))
+    (build-system composer-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'phpunit-point-to-right-listener
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "phpunit.xml.dist"
+               (("vendor\
+(/mockery/mockery/library/Mockery/Adapter/Phpunit/TestListener\\.php)" a file)
+                (search-input-file
+                 inputs (string-append "share/web" file)))))))))
+    (native-inputs
+     (list php-phpunit-phpunit php-mockery-mockery))
+    (inputs (list php-webmozart-assert
+                  php-phpdocumentor-reflection-common
+                  php-phpdocumentor-type-resolver))
+    (synopsis "Library for retrieving documentation in code from the code")
+    (description "This package provides PHP support for annotations via
+DocBlocks or otherwise retrieve information that is embedded in a DocBlock.")
+    (home-page "https://github.com/phpDocumentor/ReflectionDocBlock")
+    (license license:expat)))
+