diff mbox series

[bug#67902,08/95] gnu: Add php-doctrine-instantiator.

Message ID 20231219140934.22783-8-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-instantiator): New variable.

Change-Id: I3552f77fef0a42964f36a751cf8fe83167d1a236
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 438034e50c..51a5f6a3f6 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -190,3 +190,25 @@  (define-public php-doctrine-event-manager
     (home-page "https://www.doctrine-project.org/projects/event-manager")
     (license license:expat)))
 
+(define-public php-doctrine-instantiator
+  (package
+    (name "php-doctrine-instantiator")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/instantiator")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y8ajlwdzrw92lx6bnc5p7lwgrgbf602lqlyxfrsff7x538as73n"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Utility for instantiating PHP objects")
+    (description "This package provides a small, lightweight utility to
+instantiate objects in PHP without invoking their constructors")
+    (home-page "https://www.doctrine-project.org/projects/instantiator")
+    (license license:expat)))
+