diff mbox series

[bug#67902,16/95] gnu: Add php-myclabs-deep-copy.

Message ID 20231219140934.22783-16-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-myclabs-deep-copy): New variable.

Change-Id: I24ef64da525ce084e864dfa02eb12461755458cf
---
 gnu/packages/php-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index da2cc7f56e..36e1c71b9f 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -444,3 +444,32 @@  (define-public php-mockery-mockery
     (home-page "https://github.com/mockery/mockery")
     (license license:bsd-3)))
 
+(define-public php-myclabs-deep-copy
+  (package
+    (name "php-myclabs-deep-copy")
+    (version "1.11.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/myclabs/DeepCopy")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1jica9cx65a3l70p1sn6vjz5dxdqfwf5msvn1v4qnp6ah7rh4xcv"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--bootstrap" "vendor/autoload.php")))
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-doctrine-collections
+           php-doctrine-common
+           php-phpspec-prophecy))
+    (synopsis "Create copies of PHP objects")
+    (description "This package contains a facility to create deep copies (clones)
+of PHP objects.  This package not only creates a new copy of an object, it
+recursively create new copies of any object referenced by the object.  It is
+designed to work even in the presence of cycles in the association graph.")
+    (home-page "https://github.com/myclabs/DeepCopy")
+    (license license:expat)))
+