diff mbox series

[bug#67902,30/95] gnu: Add php-phpunit-php-token-stream.

Message ID 20231219140934.22783-30-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-token-stream): New variable.

Change-Id: I97e5eb6cdceddad3aa02481db0d39c8fc5f53779
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 53b8fcd284..b6fb3e0ac2 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -808,3 +808,25 @@  (define-public php-phpunit-php-text-template
     (home-page "https://github.com/sebastianbergmann/php-text-template/")
     (license license:bsd-3)))
 
+(define-public php-phpunit-php-token-stream
+  (package
+    (name "php-phpunit-php-token-stream")
+    (version "4.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/php-token-stream")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17pyrfxvjld57i43wanfk84d8x327lwmn1avk6hbwapn4bxic0lv"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (home-page "https://github.com/sebastianbergmann/php-token-stream")
+    (synopsis "Wrapper around PHP's tokenizer extension")
+    (description "This library provides a wrapper around PHP's tokenizer
+extension.")
+    (license license:bsd-3)))
+