diff mbox series

[bug#67902,86/95] gnu: Add php-symfony-var-dumper.

Message ID 20231219140934.22783-86-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-var-dumper): New variable.

Change-Id: I11abab742960fd65b88867729c0e28ce8f947601
---
 gnu/packages/php-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 833401dc20..1a2fcba136 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2334,3 +2334,30 @@  (define-public php-symfony-uid
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-var-dumper
+  (package
+    (name "php-symfony-var-dumper")
+    (version "6.0.19")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/var-dumper")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0mnbwsy3as81d94plgxaqpwacznhv2gp45q5h737shfhgyxx9ms3"))))
+    (build-system composer-build-system)
+    ;; Native inputs here create a loop that is hard to break.
+    ;; Maybe use a -bootstrap version if testing becomes important.
+    (arguments
+     '(#:tests? #f))
+    (inputs
+     (list php-symfony-deprecation-contracts php-symfony-polyfill-mbstring))
+    (synopsis "Walk through any PHP variable")
+    (description
+     "This package provides mechanisms for walking through any arbitrary PHP
+variable.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+