diff mbox series

[bug#67902,46/95] gnu: Add php-sebastian-global-state.

Message ID 20231219140934.22783-46-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-global-state): New variable.

Change-Id: I3badfb2486751d423f32a6e6b13e4f33eb1358cc
---
 gnu/packages/php-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 97bb12a2fb..2b93d56432 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1162,3 +1162,28 @@  (define-public php-sebastian-exporter
     (home-page "https://github.com/sebastianbergmann/exporter")
     (license license:bsd-3)))
 
+(define-public php-sebastian-global-state
+  (package
+    (name "php-sebastian-global-state")
+    (version "5.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/global-state")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0vchgv62hy58dkz2gqa9h6yv6c8kvygc84kvbsd5h6nhlcwfzygr"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-sebastian-recursion-context php-sebastian-object-reflector))
+    (synopsis "Snapshotting of global state")
+    (description "This package contains a stand-alone component originally part
+of PHPUnit.  It provides support for creating a snapshot of the global state
+of a PHP program.")
+    (home-page "https://github.com/sebastianbergmann/global-state")
+    (license license:bsd-3)))
+