diff mbox series

[bug#67902,62/95] gnu: Add php-symfony-event-dispatcher.

Message ID 20231219140934.22783-62-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-event-dispatcher): New variable.

Change-Id: Idfe2d10c39a2890ceb23b96013a98a7966f9dffd
---
 gnu/packages/php-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 98e11e860c..1d5f033585 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1650,3 +1650,36 @@  (define-public php-symfony-error-handler
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-event-dispatcher
+  (package
+    (name "php-symfony-event-dispatcher")
+    (version "6.3.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/event-dispatcher")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "10dnagg5939knb3xqym1dcnkcpf7cjzylk3r7d80l9khgxmw8gr8"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-symfony-event-dispatcher-contracts))
+    (native-inputs
+     (list php-phpunit-phpunit
+           (package/inherit php-symfony-config
+             (arguments '(#:tests? #f))
+             (native-inputs '()))
+           (package/inherit php-symfony-dependency-injection
+             (arguments '(#:tests? #f))
+             (native-inputs '()))
+           php-symfony-error-handler
+           php-symfony-stopwatch))
+    (synopsis "Dispatch events between PHP application components")
+    (description
+     "This package provides tools that allow your application components to
+communicate with each other by dispatching events and listening to them.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+