diff mbox series

[bug#67902,42/95] gnu: Add php-sebastian-complexity.

Message ID 20231219140934.22783-42-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-complexity): New variable.

Change-Id: I6a817b9bb5a34c742dadbd9ce95e14710566cd91
---
 gnu/packages/php-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index c5d51d5d84..2a671e37c3 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1072,3 +1072,27 @@  (define-public php-sebastian-comparator
     (home-page "https://github.com/sebastianbergmann/comparator")
     (license license:bsd-3)))
 
+(define-public php-sebastian-complexity
+  (package
+    (name "php-sebastian-complexity")
+    (version "2.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/complexity")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0mrivs3dxv4kyy9js6n33ardqnijg9v6jiiypb7b97xgmf4w694w"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-nikic-php-parser))
+    (synopsis "Calculate the complexity of PHP code")
+    (description "This package provides a PHP library for calculating the
+complexity of PHP code units.")
+    (home-page "https://github.com/sebastianbergmann/complexity")
+    (license license:bsd-3)))
+