diff mbox series

[bug#67902,58/95] gnu: Add php-symfony-console.

Message ID 20231219140934.22783-58-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-console): New variable.

Change-Id: I45f446c29a1fcbf4105388ecde89c3b6045d3826
---
 gnu/packages/php-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index a638d5db73..331b54be35 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1492,3 +1492,55 @@  (define-public php-symfony-config
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-console
+  (package
+    (name "php-symfony-console")
+    (version "6.3.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/console")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1k6vncnkrd80ly965b1a648gyc47yy24vy2hx75842l62xj280p2"))))
+    (build-system composer-build-system)
+    (arguments
+     (list
+      #:test-flags ''("--exclude" "skipTest")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'fix-tests
+            (lambda _
+              ;; Deactivate failing tests.
+              (substitute* "Tests/Helper/QuestionHelperTest.php"
+                (("(.*)public function testAutocompleteMoveCursorBackwards" all blank)
+                 (string-append
+                  blank "/**\n"
+                  blank " * @group skipTest\n"
+                  blank " */\n"
+                  all))))))))
+    (inputs
+     (list php-symfony-polyfill-mbstring
+           php-symfony-deprecation-contracts
+           php-symfony-service-contracts
+           php-symfony-string))
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-psr-log
+           php-symfony-dependency-injection
+           php-symfony-event-dispatcher
+           (package/inherit php-symfony-lock
+             (arguments '(#:tests? #f))
+             (native-inputs '()))
+           php-symfony-phpunit-bridge
+           php-symfony-process
+           php-symfony-var-dumper))
+    (synopsis "Create PHP CLI applications")
+    (description
+     "This package provides utilities to ease the creation of beautiful and
+testable command line interfaces.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+