diff mbox series

[bug#67902,18/95] gnu: Add php-phar-io-manifest.

Message ID 20231219140934.22783-18-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-phar-io-manifest): New variable.

Change-Id: Idfb14ce342d8e8593fafe5a97f37bcba0779dda7
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index e750504485..5414e34266 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -495,3 +495,25 @@  (define-public php-nikic-php-parser
     (home-page "https://github.com/nikic/PHP-Parser")
     (license license:bsd-3)))
 
+(define-public php-phar-io-manifest
+  (package
+    (name "php-phar-io-manifest")
+    (version "2.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/phar-io/manifest")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "10bj0c38a988mwv0h8g7lk2npyghsf0bzbvys1msxlckjy7b1zww"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-phar-io-version))
+    (synopsis "PHP Archive information reader")
+    (description "This package contains a component for reading phar.io manifest
+information from a PHP Archive (PHAR).")
+    (home-page "https://phar.io")
+    (license license:bsd-3)))
+