diff mbox series

[bug#67902,89/95] gnu: Add php-doctrine-cache.

Message ID 20231219140934.22783-89-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-cache): New variable.

Change-Id: I4db60b0dfc7bd84eb698cb10812fc48b8238f788
---
 gnu/packages/php-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 89130274e0..036554b8ab 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2415,3 +2415,37 @@  (define-public php-symfony-yaml
     (home-page "https://symfony.com")
     (license license:expat)))
 
+;; This package is placed here because it needs to be defined after
+;; php-symfony-cache due to package inheritance.
+(define-public php-doctrine-cache
+  (package
+    (name "php-doctrine-cache")
+    (version "2.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/cache")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0dq1sylirjhps485s748qmb79cz64njs9wy9qxj10h3r01b6knz6"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--bootstrap" "vendor/autoload.php")))
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-psr-cache
+           php-cache-integration-tests
+           (package/inherit php-symfony-cache
+             (arguments '(#:tests? #f))
+             (native-inputs '()))
+           php-symfony-var-exporter))
+    (synopsis "PHP cache library")
+    (description
+     "This package provides a PHP cache popular library.  This implementation
+supports many different drivers such as redis, memcache, apc, mongodb and
+others.")
+    (home-page "https://www.doctrine-project.org/projects/cache")
+    (license license:expat)))
+