diff mbox series

[bug#67902,41/95] gnu: Add php-sebastian-comparator.

Message ID 20231219140934.22783-41-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-comparator): New variable.

Change-Id: I7ab566fde1bef653ea59f412d0808ec29ede8275
---
 gnu/packages/php-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index a7dfc71746..c5d51d5d84 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1048,3 +1048,27 @@  (define-public php-sebastian-code-unit-reverse-lookup
     (home-page "https://github.com/sebastianbergmann/code-unit-reverse-lookup")
     (license license:bsd-3)))
 
+(define-public php-sebastian-comparator
+  (package
+    (name "php-sebastian-comparator")
+    (version "4.0.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/comparator")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00manwzfmsk8vkvra63mbpimkhr8sq9qi1dm3rdkspizy4gg0idl"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-sebastian-exporter php-sebastian-diff))
+    (synopsis "PHP value comparison")
+    (description "This package provides the functionality to compare PHP values
+for equality.")
+    (home-page "https://github.com/sebastianbergmann/comparator")
+    (license license:bsd-3)))
+