diff mbox series

[bug#67902,73/95] gnu: Add php-symfony-process.

Message ID 20231219140934.22783-73-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-process): New variable.

Change-Id: I90eafe94a8f22ce857d163ba3d71999900fa49d8
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index d6a49d1f75..bbe6f6aa01 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2031,3 +2031,25 @@  (define-public php-symfony-phpunit-bridge
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-process
+  (package
+    (name "php-symfony-process")
+    (version "6.3.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/process")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "05jp156j8gxgm9ksxdmbmx1h844k02pml4iq9v54l04iah2qgi7k"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Subprocesses in PHP")
+    (description "This package provides the functionality to execute commands
+in sub-processes.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+