diff mbox series

[bug#67902,44/95] gnu: Add php-sebastian-environment.

Message ID 20231219140934.22783-44-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-environment): New variable.

Change-Id: I1b1e30bb547ffc6e105f2a6ae711d7a3d8029233
---
 gnu/packages/php-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 51a96948b3..53da205216 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1117,3 +1117,24 @@  (define-public php-sebastian-diff
     (home-page "https://github.com/sebastianbergmann/diff")
     (license license:bsd-3)))
 
+(define-public php-sebastian-environment
+  (package
+    (name "php-sebastian-environment")
+    (version "5.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/environment")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zfgwzvk1nrib9k5iz8x51g70222qw7kjyh34gp6zaqjsj6dpbiw"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Handle HHVM and PHP environments")
+    (description "This package provides functionality to handle HHVM/PHP environments")
+    (home-page "https://github.com/sebastianbergmann/environment")
+    (license license:bsd-3)))
+